(inteD) Galileo

Intel® Galileo Board
Getting Started Guide

23 December 2013

Order Number: 329685-005US



( i n tel ’ Intel® Galileo Board Getting Started Guide

Getting Started Guide

Note:

This document explains how to connect your Intel® Galileo board to the computer,
install the software on your computer, and upload your first sketch.

You should be able to do this in under an hour (not counting your download time).

This release uses a special version of the Arduino IDE. The first thing you must do is
download it from the Intel website below and update the SPI flash on the board.

The basic steps you will follow are:
Get a board and cables

Download the Arduino environment and board firmware
Connect the board

Install the drivers and other software

Launch the Arduino IDE application

Update your board firmware

Open the blink example

Select your board
. Select your serial port
10. Upload the program

Vo NOU AWM

See these sections for advanced tasks:
11. Booting your board from an SD card (mandatory for WiFi)
12. Manually update your board firmware (optional)

For more information about Intel® Galileo, including online communities and support,
try these links:

http://www.intel.com/support/galileo

http://communities.intel.com/community/makers

Get a board and cables

The kit contains:
e 1x Intel® Galileo Customer Reference Board (CRB) (Fab D with blue PCB)

e 1x 5v power supply with cable
Warning: You must use a power supply or you will damage the board!
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Intel® Galileo Board

Note:

2.

Note:

Order Number:

USB Client Port and
Programming Port

Y

Reset button for Reboot button for
sketch and shield(s) Intel® Quark SoC

The I/0 headers are identical to the Arduino Revision 1.0 pinout.

Download the Arduino environment and board firmware

Download the latest IDE and firmware files here:
https://communities.intel.com/community/makers/drivers

You will need up to 200 MB of free space, depending on which OS you are using.

When unzipping the packages:

— Extract the package into the c:\ directory due to a known issue unzipping
packages with long file paths.

— Use an unzip tool that supports an extended file path (for example, 7-zip from
http://www.7-zip.org/).

This release contains multiple zip files, including:

. Operatlng system-specific IDE packages, contain automatic SPI flash update:
Intel Galileo Arduino SW_1.5.3 on Linux32bit v0.7.5.tgz (72.2 MB)
— Intel Galileo Arduino SW_1.5.3 on Linux64bit v0.7.5.tgz (73.5 MB)
— Intel Galileo Arduino SW _1.5.3 on MacOSX v0.7.5.zip (54.3 MB)
— Intel Galileo Arduino SW _1.5.3 on Windows v0.7.5.zip (104 MB)

e (Mandatory for WiFi) Files for booting board from SD card. See Section 11.
LINUX IMAGE FOR SD Intel Galileo v0.7.5.7z (36.7 MB)
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e (Optional) Files for updating SPI flash manually. See Section 12 for details.
LITTLE LINUX IMAGE FirmwareUpdate Intel Galileo v0.7.5.7z (5.5 MB)
— Capsulelpp.efi
— sysimage Intel Galileo v0.7.5.cap

e (Optional) Board Support Package (BSP) sources:
The BSP build process requires additional 30 GB of free disk space.
— Board Support Package Sources_ for Intel Quark v0.7.5.7z (3.2 MB)

e (Optional) Board Support Package (BSP) sources including Yocto archive:
The BSP build process requires additional 30 GB of free disk space.
Board Support Package Sources for Intel Quark v0.7.5 full yocto archive.tar.gz

(925 MB)

If you are working with the BSP sources, see the Inte/® Quark SoC X1000 BSP
Build Guide [https://communities.intel.com/docs/DOC-21882]

Windows*:
1. Unzip the IDE file to the c:\ directory.
2. Make sure to preserve the folder structure. Double-click the folder to open it.

If you are updating your IDE, be sure to uninstall the previous IDE version first.

Linux*:

1. In your home directory, extract the package with the appropriate command:
tar -zxvf arduino-1.5.3-1inux32.tar.gz

or
tar -zxvf arduino-1.5.3-1linux64.tar.gz

2. To avoid interference with the IDE, you must disable modem manager. The exact
command will depend on your Linux distribution.
For example, the command sudo apt-get remove modemmanager may work

3. In the same directory where the package was downloaded, launch the Arduino IDE
by executing ./arduino

Note: The first time you compile and install a sketch, the Galileo software will be
installed automatically. This requires appropriate file and directory access
permissions. You may be required to run the IDE as root or using
sudo arduino depending on your Linux distribution.

Mac OS*:

Caution: You must unzip the IDE on your Mac’s normal hard disk. Once the IDE is
unzipped, you cannot run it from or transfer it to USB drives or any other
media formatted for use in Windows computers or it will be corrupted.

1. Download the zip file on the Mac hard drive and unzip it.
2. Drag and drop the Arduino application onto the Applications folder on your Mac.

3. Connect the board

WARNING: You must use the power supply or you will damage the board.
Connect the 5V power cable to the Galileo board and to a power outlet.

Note: Always connect the 5V power before any other connection.

The green power LED (labelled ON) will turn on.
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4.

Order Number:

Install the drivers and other software

Windows:

1.

If not done already, connect the 5V power cable to the Galileo board and to a
power outlet.

Note: Always connect the 5V power before the USB connection.

2.

Connect the USB cable to the USB Client Port (closest to the Ethernet) and to a
PC. Wait for Windows to begin its driver installation process. After a few moments,
the process will fail.

Click on the Start Menu, and open up the Control Panel. While in the Control
Panel, navigate to System. Next, click on System. Once the System window is
up, open the Device Manager.

Look under Ports (COM & LPT). You should see an open port named Gadget
Serial V2.4. If you do not see this open port, follow steps a-c in the Note below.

Right-click on the Gadget Serial V2.4 port and choose the Update Driver
Software option.

Choose the Browse my computer for Driver software option.

Navigate to the hardware/arduino/x86/tools directory. This allows the proper
driver file 1inux-cdc-acm.inf to be installed.

Once the driver is successfully installed, Device Manager will show a
Galileo (COMXx) device under Ports (COM & LPT). Note the COMx port number
as it will be needed in the IDE later. The example below shows COMS5.

» B Monitars

|_.‘Ir Metwork adapters

’ J57 Ports (COM & LPT)

‘? Communications Port (COM1)
_J2T ECP Printer Port (LPT1)

[ 7% Galileo (cOMS) ]

. Ll Processors

b [P Security Devices

Note: You may find Gadget Serial 2.4 under Other devices in Device Manager. If
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this is the case, do the following:

a. In Windows Explorer, go to C:\Windows\System32\drivers and look for
usbser.sys. If it is present, you can skip these steps. If it is missing,
copy usbser.sys from the archive location identified below:

Windows 7:
C:\Windows\System32\DriverStore\FileRepository\mdmcpqg.inf amdé6

4 neutral fbc4ald4a6al3d0c8\usbser.sys (archive file)

Windows 8:
C:\Windows\System32\DriverStore\FileRepository\mdmcpqg.inf amdé6

4 d9e0b9c4fel44bdd\usbser.sys (archive file)

b. In Windows Explorer, copy to: C:\Windows\System32\drivers
You may need to provide Administrator Permission to complete the copy.

c. Once usbser.sys is copied, continue with step 5 above.
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Linux:

1. If not done already, connect the 5V power cable to the board and to a power
outlet. Wait for the board to boot.

Note: Always connect the 5V power before the USB connection.

2. Connect the USB cable to the USB Client Port (closest to the Ethernet) and to a
PC.

3. Check that ACM port is available by typing in the terminal 1s /dev/ttyacM*

Note: If the /dev/ttyacMO port is not present, follow the procedure below:

a. Create afile etc/udev/rules.d/50-arduino.rules and add the following:
KERNEL=="ttyACM[0-9]*", MODE="0666"

b. Restart the udev with the following command: sudo service udev restart
If you are using a virtual machine (VM), you may need to reboot Linux within
the VM.

4. Launch the IDE.
The first time you compile and install a sketch, the Galileo software will be
installed automatically. This requires appropriate file and directory access

permissions. You may be required to run the IDE as root or using sudo arduino
depending on your Linux distribution.

5. Select your board via Tools > Board > Intel® Galileo
6. Select the port Tools > Serial Port > /dev/ttyAMCO

Note: If the serial ttyaCcMO is not available, make sure you have the proper rights to
access the ports. If the serial port is disabled on your IDE, exit the IDE and
execute again using the command: sudo arduino

Mac OS:

The Galileo board is supported by the Mac OS built-in USB drivers, however, the board
has to boot for it to show up because the port is driven by software on the board.

1. If not done already, connect the 5V power cable to the board and to a power
outlet. Wait for the board to boot.

Note: Always connect the 5V power before the USB connection.

2. Connect the USB cable to the USB Client Port (closest to the Ethernet) and to your
Mac. Check the System Profiler > USB setting to be sure that Gadget Serial is
selected. If you are installing a new version of the IDE, you may need to re-select
this setting.

3. In the Arduino IDE, the correct serial port shows in the Tools > Serial Port menu
as /dev/cu.usbmodemnnnnn where nnnnn is a number such as fd121.

Do not select the /dev/tty port.

5. Launch the Arduino IDE application
Windows: In the folder arduino-1.5. 3, double-click arduino.exe

Linux: In the folder arduino-1.5.3, launch Arduino by executing ./arduino
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Order Number:

Note: You may see an error stating Java is not present. If you are using Ubuntu, run
the command sudo apt-get install default-jre to clear this error.

Mac OS: Double-click the Intel Galileo Install disk image. When the disk volume
mounts, drag and drop the Arduino application on your Applications folder.

Update your board firmware

The IDE contains the release-specific firmware for your board. Follow the steps below
to update your board firmware using the IDE.

1. Remove all power from the board (USB and 5 V power cord). This makes sure that
no sketch is running on the board.

2. Remove the SD card from the board (if it is inserted).
3. Power up the board by plugging in the 5V power supply.

4. Connect the USB cable to the USB Client Port (closest to the Ethernet).
Note which COM port it is connected on.

5. Launch the IDE and select the board via Tools > Board > Intel® Galileo
6. Select the correct serial port using Tools > Serial Port

Note: Do not download any sketch to the board before you upgrade the firmware.

7. Launch the software upgrade using Help > Firmware Upgrade

8. A message is displayed asking you to confirm that 5V power cable is plugged in.
Click Yes if it is connected. If no cable is plugged in, exit the upgrade process by
selecting No, connect the power, and restart this process.

9. The board can be upgraded to newer software or downgraded to older software.
The next message displays the current software version that is on the board and
the software version that you are trying to flash onto the board. Select Yes to
either Upgrade/Downgrade or flash the same software again.

10. The upgrade progress takes about 6 minutes and is displayed in several popup
messages. During the upgrade process, you will not have access to the IDE.

Note: The power and USB cables must stay connected during the upgrade process.

11. When the upgrade completes, a message is displayed stating Target Firmware
upgraded successfully. Click OK to close the message.

If you want to flash a different firmware version that is not contained in the IDE,
download the SPI flash image capsule files as described in Section 2.

The downloaded capsule should be copied to the following locations, depending upon
your operating system. Make sure that there is only one *.cap file in the location
below. If you are downloading a new file, rename the previous *.cap to some other
extension.

e Windows: Arduino-1.5.3/hardware/tools/x86/bin/
e Linux: Arduino-1.5.3/hardware/tools/
e Mac OS: Arduino.app/Contents/Resources/Java/hardware/tools/x86/bin/

Note: If you see a failure at any stage of the upgrade, refer to the Release Notes for
known issues and possible workarounds.
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7.

10.

11.

Note:

Open the blink example

Open the LED blink example sketch: File > Examples > 1.Basics > Blink.

Select your board

Select Tools > Board > Intel® Galileo.

Note: If the IDE was closed and then reopened, it will default to a board that was
previously selected. You may need to explicitly select Intel® Galileo.

Select your serial port

Select the serial device of your board from the Tools > Serial Port menu.
Windows: Use the COMx number assigned earlier. You can retrieve the port number
by navigating to:

Start > Control Panel > System and Security > System > Device Manager
Look under Ports (COM & LPT) to see which COMx is assigned to Gadget Serial.

Linux: Use /dev/ttyAMCO

Mac 0S: Use /dev/cu.usbmodemnnnnn

Upload the program

Click the Upload button in the IDE and wait a few seconds. If the upload is successful,
the message Done uploading. will appear in the status bar.

A few seconds after the upload finishes, you will see a green LED on the board start to
blink. Congratulations! You've gotten your board up and running.

For more information about Intel® Galileo, including online communities and support,
try these links:

http://www.intel.com/support/galileo

http://communities.intel.com/community/makers

Booting your board from an SD card (mandatory for WiFi)

Follow these steps to boot your board from an SD card. This setup also allows you to
save your sketch to the Galileo board, so it will be able to repeat sketches after board
power-down. (These steps create a persistent /sketch folder and rootfs.)

If you want to use WiFi, you must follow these steps. The WiFi driver is not present in
the Linux image in SPI flash because it is too large. The Linux SD image also includes
ALSA, V4L2, python, SSH, node.js, and opencCV.

Required files are in the LINUX IMAGE FOR SD Intel Galileo v0.7.5.7z zip file
(download link in Section 2).
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Note: Your SD card must meet the following requirements:
SD card must be formatted as FAT or FAT32.

SD card size must be less than 32GB.

1. Copy all files and directories from the zip file to your SD card.

You do not need to create a directory on the SD card. The zipfile contains all the
necessary files and structure. Be sure it is extracted at the top level of the SD
card. See the screenshot below for a sample view.

File Edit View Tools Help

Organize = Share with = Burn Mew folder Bz~ M '@'
i Mame ‘ Date modified Type Size
N t

Ta Z;;u:rc | boot 27/09/2012 14557 File folder
'i' - (;) ) L [ badmage 27/00/201312:26  File 2,064 KB
| t' builds diet001 |E| 2 core-image-minimal-initramfs-clanton.cpio.gz  27/09/2013 1500  WinZip File 1,401 KB

. Clanton_swbuilds_disl e

- - || image-full-clanten.ext3 31/12/2000 2301 EXT3 File 307,200 KB

. clanton_swvalidation_disk001
. disks -

2. Insert the SD card, then power on the board.
Note: The first time you boot the board may take several minutes. This is expected behavior
due to the SSH component creating cryptographic keys on the first boot.

Troubleshooting tip: you may need to add a boot partition to your SD card. To do
this on a Windows machine, perform the following:

Open a cmd.exe instance as an Administrator.

Run diskpart.exe and run the following commands:
select vol <a>; (where <a> = the drive letter of the SD card)

clean;

create part primary;

active;

format gquick label="BOOTME";
exit

12. Manually update your board firmware (optional)

Note: This method has been replaced by functionality in the IDE. It is provided for reference
only.

You must update the firmware the first time you use the board to ensure the firmware
on the board is in sync with the IDE.

These steps assume you have a microSD card inserted into the slot on the board,
which contains the release-specific sysimage nnnn.cap file and the Capsulefpp.efi

file.
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The capsuleapp.efi and the *.cap file are a matched pair and must be used
together. When a new *.cap file is released, you must use the corresponding
CapsuleApp.efi to install it.

Perform the steps below:

1.
2.

Download the SPI flash image capsule files as described in Section 2.

Copy Capsuleipp.efi and sysimage nnnnn.cap to a microSD card and insert it
into the slot on the board.

Connect the serial cable between the computer and the Galileo board. Set up a
serial console session (for example, PUTTY) and connect to the Galileo board’s
COM port at 115200 baud rate.

Configure the serial console session to recognize special characters. For example,
if you are using PuTTY, you must explicitly enable special characters. In the PuTTY
Configuration options, go to the Terminal > Keyboard category and set the
Function keys and Keypad option to sco.

Power on the board. A GNU GRUB boot loader menu is displayed (below).
Exit GRUB by entering c and quit as shown below.

Press c to get a command line.
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At the GRUB command line, type quit.

6. The serial console displays a boot device selection box (below).
Select UEFI Internal Shell.

Order Number: 329685-005US
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7. You will see a print out, the top line of which looks like this:
fs0 :HardDisk - Alias hd7b blkO0

This is your SD card. To mount it, type: fso0:

8. Verify you are using the correct version of CapsuleApp.efi by using the -v
option. You must use version 1.01 or later.

9. Enter the following command:
CapsuleApp.efi sysimage nnnnn.cap

Note: You must enter the full filename of the sysimage nnnnn.cap file.

You will see a display similar to this:

Order Number: 329685-005US



®

Intel® Galileo Board Getting Started Guide i n t el

The capsuleapp will update your SPI flash image. This process takes about 2
minutes.

Warning: DO NOT remove power or try to exit during this process. Wait for the
prompt to return, otherwise your board will become non-functional.

10. When the update completes, reboot the board by removing and reconnecting the
power cable. You will see a display similar to this:

or inwvalid permi

1.4.1 clanton /de
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Revision History

Date Document Description
Revision
23 December 2013 005 Updated kit contents list.

Updated filename/size of Board Support Package (BSP) sources
including Yocto archive.

Added Troubleshooting tip for Booting from SD card section.

16 October 2013 004 Updated download URL and other minor text updates.
10 October 2013 003 Updated file names and sizes.
04 October 2013 002 Added links to maker community and support pages.

Updated board picture with additional callouts.

02 October 2013 001 First external release: Package Version: 0.7.5 for Arduino IDE v1.5.3
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